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A server rejects the INFO request from a client by using a "401 Unauthorized" response in a Lync Server 2010 environment


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Symptoms

Consider the following scenario:
  • You deploy the Remote Call Control (RCC) functionality in a Microsoft Lync Server 2010 environment.
  • A REGISTER request is sent to the Lync Server 2010 server when an RCC-enabled user signs out of the Lync 2010 client.
  • The client sends an INFO requestthat contains the MonitoringStop eventto the server after a “200 OK” response.
In this scenario, the Lync Server 2010 server rejects the INFO request and then responds with a “401 Unauthorized error message. Additionally, the INFO requestis not passed to theSIP/CSTA gateway.

Note The gateway does not receive the MonitoringStop events from the Lync 2010 clients to close the connection. The gateway might be down because of too many active connections.

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Cause

This issue occurs because the INFO request does not contain the Proxy-Authorization header. Therefore, the server rejects the request.

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Resolution

To resolve this issue, install either of the following cumulative updates:
2647415 Description of the update for Lync 2010: November 2011
2670326 Description of the cumulative update for Lync 2010: February 2012

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More Information

For more information about RCC, visit the following Microsoft website:


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Keywords: kbqfe, kbsurveynew, kbfix, kbexpertiseadvanced, kb

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Article Info
Article ID : 2644148
Revision : 1
Created on : 1/7/2017
Published on : 3/1/2012
Exists online : False
Views : 304